Hello guys.

I am not sure if this is the right forum, however, i am unable to register on ghost++ forums (mail just didn't come). Anyway... to issue.

I am trying to host Ghost++ bot ... i tried to install it both on linux and windows .. a tried a lot of versions (Ghost++, Aura, GhostOne, etc.)

I have properly forwarded ports (6112, 6113, 6114 ... ), checked through telnet and also https://www.yougetsignal.com/tools/open-ports/ looks fine.

I started bot
Code:
[CONFIG] loading file [default.cfg][CONFIG] loading file [ghost.cfg]
[GHOST] starting up
[GHOST] using log method 1, logging is enabled and [ghost.log] will not be locked
[GHOST] using Windows timer with resolution 1 milliseconds
[GHOST] starting winsock
[GHOST] setting process priority to "above normal"
[UDPSOCKET] using default broadcast target
[GHOST] opening primary database
[SQLITE3] version 3.7.13
[SQLITE3] opening database [ghost.dbs]
[SQLITE3] found schema number [8]
[GHOST] opening secondary (local) database
[SQLITE3] version 3.7.13
[SQLITE3] opening database [ghost.dbs]
[SQLITE3] found schema number [8]
[GHOST] attempting to find local IP addresses
[GHOST] local IP address #1 is [127.0.0.1]
[GHOST] local IP address #2 is [92.63.57.120]
[GHOST] acting as Warcraft III: The Frozen Throne
[CONFIG] loading file [language.cfg]
[GHOST] found battle.net connection #1 for server [server.eurobattle.net]
[GHOST] using system locale of 1033
[BNET: XPAM] pvpgn connection found with a configured BNLS server, ignoring BNLS server
[GHOST] loading MPQ file [C:\wamp64\www\cloud\backend\web\ghost\warcraft\War3x.mpq]
[GHOST] extracting Scripts\common.j from MPQ file to [mapcfgs\common.j]
[GHOST] extracting Scripts\blizzard.j from MPQ file to [mapcfgs\blizzard.j]
[GHOST] adding ".cfg" to default map -> new default is [DotA v6.83d.cfg]
[CONFIG] loading file [mapcfgs\DotA v6.83d.cfg]
[MAP] loading MPQ file [maps\DotA Allstars v6.83d.w3x]
[MAP] calculated map_size = 79 105 125 0
[MAP] calculated map_info = 46 216 6 22
[MAP] calculated map_crc = 243 206 235 58
[MAP] calculated map_sha1 = 144 68 223 66 85 161 230 87 173 245 24 46 111 9 125 107 144 149 250 14
[MAP] calculated map_options = 96
[MAP] calculated map_width = 118 0
[MAP] calculated map_height = 120 0
[MAP] calculated map_numplayers = 10
[MAP] calculated map_numteams = 2
[MAP] calculated map_slot1 = 0 255 0 0 0 1 4 1 100
[MAP] calculated map_slot2 = 0 255 0 0 0 2 4 1 100
[MAP] calculated map_slot3 = 0 255 0 0 0 3 4 1 100
[MAP] calculated map_slot4 = 0 255 0 0 0 4 4 1 100
[MAP] calculated map_slot5 = 0 255 0 0 0 5 4 1 100
[MAP] calculated map_slot6 = 0 255 0 0 1 7 8 1 100
[MAP] calculated map_slot7 = 0 255 0 0 1 8 8 1 100
[MAP] calculated map_slot8 = 0 255 0 0 1 9 8 1 100
[MAP] calculated map_slot9 = 0 255 0 0 1 10 8 1 100
[MAP] calculated map_slot10 = 0 255 0 0 1 11 8 1 100
[MAP] adding 14 observer slots
[GHOST] using hardcoded admin game map
[MAP] using hardcoded Emerald Gardens map data for Warcraft 3 version 1.24 & 1.24b
[GHOST] started loading [ip-to-country.csv]
[GHOST] iptocountry data: 10% loaded
[GHOST] iptocountry data: 20% loaded
[GHOST] iptocountry data: 30% loaded
[GHOST] iptocountry data: 40% loaded
[GHOST] iptocountry data: 50% loaded
[GHOST] iptocountry data: 60% loaded
[GHOST] iptocountry data: 70% loaded
[GHOST] iptocountry data: 80% loaded
[GHOST] iptocountry data: 90% loaded
[GHOST] iptocountry data: 100% loaded
[GHOST] finished loading [ip-to-country.csv]
[GHOST] GHost++ Version 17.2 (with MySQL support)
[BNET: XPAM] connecting to server [server.eurobattle.net] on port 6112
[BNET: XPAM] resolved and cached server IP address 95.216.33.218
[BNET: XPAM] connected
[BNET: XPAM] using custom exe version bnet_custom_exeversion = 0 5 28 1
[BNET: XPAM] using custom exe version hash bnet_custom_exeversionhash = 201 63 116 96
[BNET: XPAM] attempting to auth as Warcraft III: The Frozen Throne
[BNET: XPAM] cd keys accepted
[BNET: XPAM] username [mzi_bot] accepted
[BNET: XPAM] using pvpgn logon type (for pvpgn servers only)
[BNET: XPAM] logon successful
[BNET: XPAM] joining channel [asdfe]
[BNET: XPAM] joined channel [asdfe]
[INFO: XPAM] you are now tempOP for this channel
[INFO: XPAM] Hello mzi_bot, welcome to a EUROBATTLE.NET server
[INFO: XPAM] This server is hosted by server.eurobattle.net
[INFO: XPAM]
[INFO: XPAM] There are currently 335 users in 146 games and chatting in 23 channels.
[INFO: XPAM]
[ERROR: XPAM] Cheating in any way is not allowed on our server.
[ERROR: XPAM] Doing so will lead to a ban.
[INFO: XPAM] Need some help?
[INFO: XPAM] Type /help for commands & // for Frequently Asked Questions,
[INFO: XPAM] Or visit us on our forum: www.eurobattle.net
[INFO: XPAM] Have Fun playing :)
[INFO: XPAM]
[INFO: XPAM] You have no mail.
[INFO: XPAM]
[LOCAL: XPAM] [abdul-alhazad] !pub test
[BNET: XPAM] admin [abdul-alhazad] sent command [!pub test]
[GHOST] creating game [test]
[GAME: hajzel] loading IP blacklist file [ipblacklist.txt]
[GAME: hajzel] loaded 635 lines from IP blacklist file
[GAME: hajzel] attempting to bind to all available addresses
[GAME: hajzel] listening on port 6113
[STATSDOTA] using dota stats
[QUEUED: XPAM] Creating public game [test] started by [abdul-alhazad].
[GameThread] Made new game thread
[GAME: test] is over (lobby time limit hit)
[GameThread] deleting game [test]
[BNET: XPAM] joining channel [asdf]
[BNET: XPAM] joined channel [asdf]
[INFO: XPAM] you are now tempOP for this channel
Everything looks fine, but i cannot find my game, there is not even screen freeze, it just instant says "The game, you attempted to join couldn't be found", after i write game name and try to join, after error message it appears in game lists, without any info and unjoinable.

I use Warcraft III patch 1.28.5 as mentioned in XPAM installation guide.

+ custom hashes

bnet_custom_war3version = 28
bnet_custom_exeversion = 0 5 28 1
bnet_custom_exeversionhash = 201 63 116 96
bnet_custom_passwordhashtype = pvpgn
Is there any way to host this properly ? Could any1 help me ? Please